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Overview @

This codelab is an introduction to how
to take a first person game made in

Unity and enhance it to have a Virtual
Reality mode using the Google
Cardboard plugin powered by Unity.




What you'll learn

© Development tools and configuration to
build Unity projects targeted for Android.

© How to design a game that can be used
in Cardboard and out of Cardboard.




What you'll learn

© Knowledge of best-practices for mobile
VR.

© Links to key information for developing
and publishing great Cardboard
applications.
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What you'll need

© Cardboard VR Viewer

© Device compatible with Cardboard
=such as Nexus 5, Samsung Galaxy S5...
© Unity 4.6.1 or greater

Q Android SDK
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What you'll need

©The cardboard plugin (286M)

=https://github.com/googlesamples/car
dboard-unity/archive/master.zip

© Game assets

=https://github.com/googlesamples/io2
015-codelabs/tree/master/cardboard-
unity



What you'll need

® The Cardboard Cardboard
Application O
(Optional). -
= https://play.google.c
om/store/apps/detail
s?id=com.google.sam
ples.apps.cardboardd
emo




"Lollygagger“: The main game play is

to travel along a path, atop a robot,
shooting Lollipop “cannonballs" at
the Androids that are lollygagging
around.




Lollygagger

© Two different Unity scenes, one for the
main menu, and one for game play.

© Ability to play in “2D” mode as well as be
able to start in Cardboard mode.
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Lollygagger

© Flinging lollipops to the targets,
triggered by touch in 2D mode, or by the
trigger on the side of Cardboard in VR

mode.
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1. First you need the Cardboard SDK

for unity.

2. Next you need the unity asset
package containing the sample
game.




Get the sample code

© Cardboard SDK for unity

= Download:
&

= Or clone :

¢« $ git clone
https://github.com/googlesamples/cardboard-
unity.git


https://github.com/googlesamples/cardboard-unity/archive/master.zip

Get the sample code

© The unity asset package containing
the sample game

=lollygagger_stepO.unitypackage

¢ https://github.com/googlesamples/i02015-
codelabs/blob/master/cardboard-
unity/assets/lollygagger_step0.unitypackag
e?raw=true






Configure Unity

© Start Unity.

© In Unity, click Edit > Preferences >
External Tools > Android SDK Location,
then select the folder where you
downloaded and unzipped the Android
SDK.



=Android SDK Location

Unity Preferences
External Tools
General External Script Editar | Wisual Studi
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=Click File > New Project and create a
new project named ‘Lollygagger’.




Import the game assets

© Import the sample game scenes and
assets into your project:

=Click Assets > Import Package >
Custom Package.

=Select the
lollygagger_stepO.unitypackage file you
downloaded



® Click Import.
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Configure the Android player

© Configure Unity to build an Android
application

© From the menu: click File > Build
Settings...

© Select Android in the platform list
© Click Switch Platform
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©In the project explorer, select Assets
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Add the game scenes to the build.

© Drag and Drop Assets/MainMenu
scene to the "Scenes In Build” list
within the Build Settings dialog.

®Then drag and drop
Assets/GameScene scene into the list
under MainMenu.
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Configure the Unity player settings

© Click Player Settings... in the Build
Settings dialog

©Then expand “Resolution and
Presentation” section by clicking on
it.

© Set the application default
orientation to Landscape Left.



8 Inspector
Playersettings

Company Name DefaultCompany

Product Name Lollygagger
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Cursor Hotspot
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© Expand the “Other Settings” section
by clicking on it.
© Enter a unique Bundle ID

=Typically this is of the form:
com.<yourcompany>.<appnhame>



Settings for Android
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© Save your project! Better safe than
Sorry :)
© Connect a device build and run!

©When prompted for a name for the
APK file, enter Lollygagger.apk.



€ Build Android
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Congratulations!

O If you can play the starter project
game on your Android device, you
are now ready to add Cardboard!
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Add cardboard to the
| main menu scene

In this lesson, you’ll import
the Cardboard SDK into the

Unity project.




Add the Cardboard SDK to the project

© From the menu in Unity: click Assets
> Import Package > Custom package

© Select
CardboardSDKForUnity.unitypackage

©Click “Open”



€ Import package ... *
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©Once the package is
opened, Click
“Import”
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Add cardboard mode to the main
menu scene

© This step adds the stereo cameras
and related scripts which are used by
the Cardboard SDK to render the

stereoscopic view needed to use
Cardboard.



Open the main menu scene

©In the project explorer, select the
Assets folder, and then double click
the MainMenu scene.

O Select the Main Camera in the Scene
hierarchy.

© From the menu, click Component >
Cardboard > Update Stereo Cameras.
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© Note: If the menu item is not there,
you'll need to re-import the assets
by clicking Assets > Reimport All.



} Change the Ul to @
4 be in world space
This step converts the main
menu from being mapped to

the Screen Space to be
mapped in the World Space .




1. Select Canvas from the Hierarchy
window, then in the inspector
panel

= Change Render Mode to World space

= Change position to (0, 0, 750)

= Change Width and Height to 640 and 480
= pivot = (.5, .5)

= Change scale to (1, 1, 1)



& Inspector
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2. Associate the Main Camera with
the Canvas.
=This is done so that Ul events can be

translated from the screen coordinates
to the world coordinates.



© Click on the Canvas

©In the properties inspector, click on
the circle control next to the Event
Camera which will bring up the
object selection dialog.

©Select the Scene tab, then Main
Camera object.



Select GameObject
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3. Check the menu location and size.

=You can do this by clicking on the Game
tab in the scene editor.
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Add the Cardboard mod
button to the menu

In this step, we add a button

to the menu that will turn on
and off "Cardboard Mode".




The prefab button

® Find the cardboardButton
(Assets/Prefabs) prefab in the project
explorer.

© In the Hierarchy panel, expand the
Canvas object and the Panel object.

© Drag and drop the cardboardButton
prefab onto the Panel object in the
hierarchy.
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Write the Cardboard Mode Script

1. Create a new script component on
the Canvas

=Select the Canvas object in the hierarchy.

=In the properties panel, scroll to the
bottom and click Add Component




=In the list of component types, scroll to
the bottom and click New Script.

=Name the script CardboardModeMgr,
and keep the language CSharp.

=Click Create and Add.



Handle Cardboard mode

© Open CardboardModeMgr script by
double-clicking on it, delete the entire
contents and paste in the following code.

@

i,

File Edit View 5Search Project Build Run  Versio

b-.,- Debug j Unity Editor

alution CardboardModeMgr.cs
Mo selection
1 References 3 usi Systems;

1 using System.Collections.Generic;
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2 Cardboard
. Plugins
. Resources 7 public class CardboardModeMgr : MonoBehaviour
) Scripts
. Shaders
|1}| CardboardModeMgr.cs
P |0 Assembly-CSharp-Editor

ct mainCamera;




© using UnityEngine;
using System.Collections;
using UnityEngine.EventSystems;
using System.Collections.Generic;
using UnityEngine.Ul;

public class CardboardModeMgr : MonoBehaviour {
// We need a reference to camera which

// is how we get to the cardboard components.
public GameObject mainCamera;



S

public void Start()
{
// Save a flag in the local player preferences to init
ialize VR mode
// This way when the app is restarted, it is in the m
ode that was last used.
int doVR = PlayerPrefs.Getint("VREnabled");
Cardboard.SDK.VRModeEnabled = doVR == 1;
CardboardHead head = mainCamera.GetCompone
nt<CardboardHead>();
head.enabled = Cardboard.SDK.VRModeEnabled;
Cardboard.SDK.TaplsTrigger = true;

}



© // The event handler to call to toggle Cardboard mode.
public void ChangeCardboardMode ()
{
CardboardHead head = mainCamera.GetComponent<Cardboa
rdHead> ();
if (Cardboard.SDK.VRModeEnabled) {
// disabling. rotate back to the original rotation.
head.transform.localRotation = Quaternion.identity;
}
Cardboard.SDK.VRModeEnabled = !Cardboard.SDK.VRModeE
nabled;
head.enabled = Cardboard.SDK.VRModeEnabled;
PlayerPrefs.Setint("VREnabled", Cardboard.SDK.VRModeEnab
led?1:0);
PlayerPrefs.Save();
}
}



Pro Tip

©When pasting code into the editor,
the script editor sometimes gets out
of sync with the Unity project.
=This is fixed by selecting Assets > Sync

Monodevelop Project (or Assets > Open
C# Project) from the Unity main menu.
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Handle VR pointing @
and clicking
In order to control the game play

while in cardboard mode, we need to
add an input module to the event

system that uses the player's gaze to
select or point to objects and use the
cardboard trigger as an input event.




® In the scene hierarchy, select the
EventSystem object.

© From the menu, select Component >
Scripts > Gaze Input Module.

© Make sure the Gaze Input Module is the
first input module in the list.

© Check the box Vr Mode Only in the
properties of the Gaze Input Module.
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Associate the camera with the other
game objects

© In order to gain access to the user’s
direction of view, or gaze, the main
camera needs to be made available to
these components.

= Select the Canvas object in the hierarchy.

= Set Main Camera for the Cardboard Mode Mgr
Componel‘lt. v || [ cardboard Mode Mgr (Script)

Script CardboardModeMgr

Main Camera




Associate the click event with the script

© In the scene hierarchy, select the
buttonCardboard object(under
Canvas/Panel) .

©In the properties inspector, scroll
down to the On Click () section.

© Click the + to add another handler.



© Make sure Runtime Only is selected

© For the game object, click the circle, and under
the scene tab, select Canvas by double clicking.

© Drop down the function selection and select
CardboardModeMgr.ChangeCardboardMode()

© Save the scene, and Save the project!




Testout the main menu!

© But enough sanity! Let’s build the
project again and run the app.

© Click on the Cardboard Button to go
into VR mode, and put your phone in
the Cardboard device.



© Look around, see how the buttons
become selected by just looking at
them!



} Add Cardboard to )
/ the Game Scene

1. This lesson updates the main game
scene to be VR enabled.

2. Specifically adding the stereoscopic
rendering, updating menu Uls and
adding trigger support.




Add Cardboard view to the Game Scene

© Open the game scene.

= |n the project explorer, select the Assets
folder, and the double click the GameScene
scene.

Q Select the Main Camera in the Scene
hierarchy.

= Since the game play is in first person, the
main camera is a child object of the player.



© From the menu, click Component >
Cardboard > Update Stereo Cameras.
This does the following:
=Adds StereoController
=Adds CardboardHead
=Creates Left and Right child cameras

=Also adds SkyboxMesh



© Note: If the menu item is not there,
you'll need to re-import the assets
by clicking Assets > Reimport All.



Add Cardboard Mode Manager script

© Adding this script will initialize
cardboard based on the mode selected in
the main menu.

= In the scene hierarchy, select the Canvas
object.

= From the menu, select Component > Scripts >
Cardboard Mode Mgr.

= Set the Main Camera property in the script to
the Main Camera.



Add the GazelnputModule script to the

EventSystem
©The GazelnputModule handles input

events, so it needs to be on every
scene.

=In the scene hierarchy, select the
EventSystem object.

=From the menu, select Component >
Scripts > Gaze Input Module.



=Make sure the Gaze v
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Save and Run!

Q File > Save scene
©File > Save project
Q File > Build and run



Change Aiming to be based on the gaze

of the player
©In the 2D world, the finger touch is

used to rotate the player in order to
aim and shoot.

©In VR mode, the rotation is done by
the actual user, and the Cardboard
SDK handles that for you!



Make the ending menu VR compatible

© Select Canvas from the Hierarchy window,
then in the inspector panel:
= Change Render Mode to World space
= Change position to (25, 0, 135)
= Change Width and Height to 240 and 180
= pivot (.5, .5)
= Change scale to (0.04, 0.04, 0.04)



Q Set the Event Camera

¥ canvas []static «

to be the Main "T|I| Layer (i

¥.% Rect Transform

Pos X Pos
Camera ca—
Width Height
240 180
d b Anchors
©Save the project I
Rotation ¥ 0 .
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Render Mode | World Space 4
a az e Sorting Layer [ Defawlt &

Order in Layer 1]




Congratulations!!!

© You've just taken a giant step to the
exciting world of Cardboard using
Unity.

© But as you can imagine, there are so

many more facets to creating
awesome Cardboard games.



m New to Cardboard? @

If you are new to Cardboard, or want
to explore it some more, your can

create a new Unity project and
import the CardboardDemoForUnity
package and run it!
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